Package profile
fqdn
- Summary: Validates fully-qualified domain names against RFC 1123, so that they are acceptable to modern browsers
- Author: ypcrts <ypcrts@users.noreply.github.com>
- License: MPL-2.0
- Homepage: https://github.com/ypcrts/fqdn
- Source: https://github.com/ypcrts/fqdn
- Number of releases: 12
- First release: 0.0.1 on 2017-06-06
- Latest release: 1.6.0 on 2026-09-28
- Latest release size: 12.3 KB (pure Python wheel)
Dependencies
Fqdn has one dependency (non-optional).View all 1 dependencies →Dependent packages
| Package | Optional | Group |
|---|---|---|
| jsonschema | true | format |
Similar packages
- tldextractAccurately separates a URL's subdomain, domain, and public suffix, using the Public Suffix List (PSL). By default, this includes the public ICANN TLDs and their exceptions. You can optionally support the Public Suffix List's private domains as well.
- rfc3987-syntaxHelper functions to syntactically validate strings according to RFC 3987.
- rfc3339-validatorA pure python RFC3339 validator
- rfc3987Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
- rfc3986-validatorPure python rfc3986 validator
- lance-namespace-urllib3-clientLance Namespace Specification
- email-validatorA robust email address syntax and deliverability validation library.