Package profile
uritools
- Summary: URI parsing, classification and composition
- Author: Thomas Kemmer <tkemmer@computer.org>
- License: MIT
- Homepage: https://github.com/tkem/uritools/
- Documentation: https://uritools.readthedocs.io/en/stable/
- Source: https://github.com/tkem/uritools/
- Number of releases: 44
- First release: 0.0.1 on 2014-02-08
- Latest release: 6.1.3 on 2026-07-23
- Latest release size: 11.7 KB (pure Python wheel)
Dependencies
Uritools has no dependency.Dependent packages
| Package | Optional | Group |
|---|---|---|
| invenio-app | false | |
| pyhanko-certvalidator | false | |
| spdx-tools | false | |
| urlextract | false |
Similar packages
- ada-urlURL parser and manipulator based on the WHAT WG URL standard
- urlextractCollects and extracts URLs from given text.
- urlobjectA utility class for manipulating URLs.
- rfc3987Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
- giturlparseA Git URL parsing module (supports parsing and rewriting)
- packageurl-pythonA purl aka. Package URL parser and builder
- uritemplateImplementation of RFC 6570 URI Templates