Package profile
python-whois
- Summary: Whois querying and parsing of domain registration information.
- Author: Richard Penman
- License: MIT License
- Homepage: https://github.com/richardpenman/whois
- Source: https://github.com/richardpenman/whois
- Number of releases: 28
- First release: 0.2 on 2013-01-08
- Latest release: 0.9.6 on 2025-10-07
- Latest release size: 114.2 KB (pure Python wheel)
Dependencies
Python-whois has one dependency (non-optional).View all 1 dependencies →Similar packages
- tldextractAccurately separates a URL's subdomain, domain, and public suffix, using the Public Suffix List (PSL). By default, this includes the public ICANN TLDs and their exceptions. You can optionally support the Public Suffix List's private domains as well.
- rfc3987Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
- disposable-email-domainsA set of disposable email domains
- idnaInternationalized Domain Names in Applications (IDNA)
- tldExtract the top-level domain (TLD) from the URL given.
- fqdnValidates fully-qualified domain names against RFC 1123, so that they are acceptable to modern bowsers
- uritoolsURI parsing, classification and composition