Package profile
usaddress-scourgify
- Summary: Clean US addresses following USPS pub 28 and RESO guidelines
- Author: Fable Turas
- Homepage: https://github.com/GreenBuildingRegistry/usaddress-scourgify
- Source: https://github.com/GreenBuildingRegistry/usaddress-scourgify
- Number of releases: 20
- First release: 0.1.0 on 2018-02-17
- Latest release: 0.7.1 on 2026-08-07
- Latest release size: 27.5 KB (pure Python wheel)
Dependencies
Usaddress-scourgify has 2 dependencies, 0 of which optional.Similar packages
- usaddressParse US addresses using conditional random fields
- ip3countryA zero-dependency, local, fast, tiny ip-address to country lookup
- ipaddrGoogle's IP address manipulation library
- email-validatorA robust email address syntax and deliverability validation library.
- uritemplateImplementation of RFC 6570 URI Templates
- rfc3987Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
- fqdnValidates fully-qualified domain names against RFC 1123, so that they are acceptable to modern bowsers